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Home Page Construction Kit v2 
 
Note: HCK version 2 requires FirstClass Client v7.1 or higher. 
 
The Home Page Construction Kit is designed to give you an easy way to build and 
maintain a robust Web Site without having to use any addition Home Page 
development software or, be an expert with html, the language of the Web.  In fact, 
you can build your web site without knowing anything at all about html. 
 
Conceptualizing Your Web Site 
The first thing you need to do before you even begin to use the Home Page 
Construction Kit is to give some thought to the information that you wish to present 
on your web site.  The key to the Home Page Construction Kit is to design the main 
page of your site and then duplicate it, replacing only the content so that your web 
site has a professional, consistent look.  This means you need to consider what 
topics will require a separate link.  Each link will require a separate document. Take 
a minute to view current web sites of other schools and teachers to get some ideas 
as to what might be appropriate.  Some examples might be: 
For a Teacher Home Page 

Homework Policy 
Course Outlines 
Current Homework 
Related Web Sites 
Resources 
Behavior Expectations 
Class/Course Calendar 
 

Constructing Your Web Site 
The first thing you will need to do on any computer you use to build and/or edit your 
web pages is merge the Home Page Construction Set form to your current logged in 
settings file. 
To do this, double-click on the 

 file found within the Home 
Page Construction Kit folder which is in the All 
Staff Conference.  When you do this, you will be 
presented with this dialog box.  Click on Update 
to merge the form.  
 
 
 
 
 
 
 
Now that you have done this, you have the ability 
to use the new form.  
 
 



Home Page Construction Kit v2  last updated 8/19/2006 
Sandra Hines BISD Instructional Technology page 2 of 13 

If you do not already have a Home Page Folder then you need to choose to have 
your Home Page Folder created by following the directions pictured below. 
 
Do not move your Home Page Folder off your Desktop, or it will not work properly. If 
you inadvertently move this folder off your Desktop, you can move it back, and it will 
work again. 

 
 
With your Home Page folder open, choose: 
File/New/New Document Special/HCK2 Web 
Page 
 
 
 
 
 
 
 
 
 
 
 
 
 

This will create a new, blank web page within your Home Page folder. 
Since this will be your main page, rename it as "Home Page" in the Page Link Name 
field – If it is not the main page, name it accordingly. 
- Each new page can be duplicated 

from a Template page that will be 
discussed later on.  
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The Header 
The header is where you place the key information about your Web Site.   
 

 
 
 
 
 
 
 
 
 
 
 
 

The example shown below has a 4 button, button bar along the top along with a 
navigation column on the left with 2 distinct sections.  A "Features" column on the 
right displays some current information. 
The Home Page Construction Set has 22 different buttons to choose from.  If you do 
not find a button to meet your needs, you can design and use your own. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Enter Your Title Line: with your name and class home page such as Mr. Smith’s Math 
Class Home Page. 
Line 2: – enter Burleson ISD 
Line 3: can be left blank for now.  
 
Email Name: is what you want the viewer to click on in order to email you. 
Email Address: should be your user ID with @burlesonisd.net 
Type a few words in the body of the webpage and look at what you have. 

Features 
Column 
 

Left 
Column 
Navigation 

Button Bar 

Header 

Banner 
Graphic 
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You can also go directly to any user's web pages if you know the user name or mail 
alias and the domain name of the server for this user. Type the web page address in 
the address field of Internet Explorer, using the following format: 
http://fc.burlesonisd.net/~first name _last name or 
http://fc.burlesonisd.net/~username 

For example, to see Michael Hill's (user name Michael Hill) web pages at 
fc.burlesonisd.net, you would type http://fc.burlesonisd.net/~Michael_Hill 

To see Michael's web pages using his ema il alias (his email address is 
mhill@burlesonisd.net), you would type http://fc.burlesonisd.net/~mhill  
 
Hope you like it so far. Now it is time to add your picture to the heading. 
 
Adding a Banner Image 
You can add a head shot image of yourself or any clipart or graphic image or your 
choice. You will want to reduce the image quality to conserve file size and note the 
pixel dimensions. (See page 13 for directions.) 
 
The file is uploaded directly to the Home Page folder or (Images folder inside the 
Home page folder) using File > Import > Import Files and Folders so that the file is 
located at the same level as the Home Page document.  If you are going to add 
several files and images, you may want to create an image folder and put all images 
and backgrounds in it. To Create an Images Folder, File> New> Folder.  Then right 
click and rename it. 
 Hint: Do not name a folder and file the same name. FirstClass will be 
confused. 
On the "Home Page" document, in the Banner/Graphic Info section, the location, 
name, height, width and scale values are entered. 
When viewed in the browser if it is obvious that the image is far too large you can 
scale the image down and change the font size increment. 

  
 
Horizontal Line 
If you wish, you can include a horizontal line to break up the header and the 
remaining portion of the screen and add fly in text. 

 

Fly-In Text  
Used sparingly, having text fly in raises the attention of your viewers.  You have the 
ability here to enter a line of text that will fly in from the left of your screen below 
your header. 
 



Home Page Construction Kit v2  last updated 8/19/2006 
Sandra Hines BISD Instructional Technology page 5 of 13 

 
Font Style and Color (on the Global Elements Tab under Header) 

 
 
Verdana Font Style is recommended as it is universally recognized as the BEST cross 
platform font for viewing on the Web. 
 
Additional Body/Footer information Click on the Body/Footer tab 
 
If you wish, you can include a line that will display the current date to your visitors 
You can also add the "Last modified date," but the Counter option is not available at 
this time.  
 
 
When you view your Home Page at this stage, you may find that you have to scroll 
down to view the footer information.  You can adjust the page height by adjusting  
 
 
 
Color Scheme/Button Bar (Still on Body/Footer) 
Color Scheme 
Choose your Background color even if you choose a background image. Now if you 
want a background image, choose it and your link colors.  
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Navigation 
You can choose between a Navigation Strip,  

 
 
A Button Bar,  

 
 
or no navigation across the top. Click on Navigation > Top Navigation Strip or Button 
Bar. You must but a check in the Include box and you can select the background, 
link and Highlight colors. 
 
 
 
 
 
 
 
 
 
 
The example below is from the Button Bar menu and shows three buttons across the 
top, linking to a School District Web Site, Calendar and to a page that includes a list 
of useful Web Sites. 
The Buttons were selected from the dropdown menu. To add your own images for 
buttons, the files must be uploaded as described above, on page 4, and should be 
small (88x49). In the Button Name, precede the file name and or folder with * to 
inform FirstClass to look in your home page folder. For instance, if the links.gif below 
was from your own files and in your images folder, it would read: *images/Links.gif 

To add more links, click on the  button. 
 

 
The first entry is made in the first line, selecting the Button name then entering the 
Display name and specifying the link path. If you are linking to an outside web page, 
copy and paste the address into the Link Path area. If you are linking to an internal 
page you are creating, type the name of the page in the Link Path area. 
 
Take another look at what you have.  
 
Side Navigation 
The Side Navigation is one place you can put the links to other documents on your 
web site. Choose colors that compliment your color scheme. 
 
If you wish to use the Side Navigation, be sure to check that option. 
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In the example below, one section is titled Student Info and below it will show two 
links, that will link to two other documents that will reside in the home page folder 
and designed based on duplicates of the template.   
 
The Header, Student Info will not link to a page so the link path will be left blank.  
The remaining two links will be directed to other pages.  In this example there will to 
be two additional documents inside the Home Page folder.  One called Homework 
Policy and the other called Behavior. 
 
 
 
 
 

 
This configuration will require an additional four pages to be added to the Home Page 
folder.  They will have to be named Homework, Outlines, Homework Policy, and 
Behavior. 
 
It’s time to take another look at your web page. 
 
If you have it the way you want it, you can create a Template or profile page from 
which all other pages will be created. The Features section is normally only used on 
the main home page so we will return to this later once we have created the 
Template. 
 

This column is what will 
appear on the web page and 
become the link that 
viewers will click on. 

This column is the actual file name 
or Internet address that is being 
linked to and does not have to be 
the same name as the link. 
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Home Page Template 
Once you have your Links, Buttons and Color Scheme selected for your main page 
and BEFORE you start to add content, you should create a Home Page Template.  
This is simply a duplicate copy of your Home Page document (before content added) 
and renamed Template which you will use as your master copy for creating all 
subsequent linked pages. The procedure is very simple. 
 
To duplicate the Home Page file, hold down the <Control> key on your computer's 
keyboard and click and drag a copy of the existing Home Page document. 
 

 
When you release the mouse button, a second copy of the document with the word 
"Copy:" in the subject field will be created. 

 
Double click to open this copy and change the Page link name to Template 
 
You should also REMOVE the check on the "Include today's date after header" check 
box as this item should only be displayed on your main Home Page. 
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Click on the Subject/Meta Tags Tab and replace the copy: in the Subject field with a 
dash, 

 
Close the template and click on it once then choose File > Properties to bring up the 
properties form for the Template document. 

Click on the Stationery box to make 
the document a Stationery item.  
Now, whenever you need to create a 
new HCK2 Page based on your 
Template, just double-click on it and a 
new copy will be produced ready for 
you to input content.  
 
When you click on the new Template 
file, a new document will be 
produced. You will need to change the 
name of the new file based on the 
web page you are creating. Then 
change the subject in Subject/Meta 
Tags.  
 
 
 
 

 
Adding Content 
You can start adding content at any time.  To add content, simply start typing in the 
message portion of each of your Home Page Construction Kit home pages. 
 
Fonts - Colors – Sizes 
Font, color, and size of the body of your text can be chosen from the menu bar 
above the body area. 
 
 
 
 Graphics 
The more graphics you have on your page, the slower your page will load.  When 
you are designing and viewing your pages on a high speed network this is not an 
issue.  However, if people are viewing your Web site over a dial-up modem 
connection, they may not wait around long enough for your pages to load. 
FirstClass uses a relatively new file format called PNG (Portable Network Graphics) 
that is both cross platform (work on PC or Mac) and compressed.   

TIP: The BEST way to insert any graphic file in to your content is to use Copy 
and Paste.  Select your graphic in your graphics program and choose Copy from 
the file menu.  Switch over to your FirstClass Home Page document and click 
where you want the graphic to be inserted and choose PASTE from the file 
menu.  FirstClass will automatically convert the image to a PNG image for you. 
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Once the graphic has been inserted in to your text you can resize it and choose the 
text wrapping features of the FirstClass Client to control how your text will be 
displayed around your graphic. 
To do this, click on the graphic 

and resize with , and position with  
 
Animated GIF files 
Many people enjoy using animated gif files in their web pages.  For licensing reasons, 
the FirstClass client no longer includes a GIF plug-in so you will not be able to see 
your GIF file in the FirstClass Client. However, any animated GIF inserted in to your 
home page documents will be displayed properly in a web browser.  
 

1. Find a copyright free animated GIF 
2. If it is on the Internet, Right click it and Select “Save Picture As” 
3. Navigate the Desktop or My Pictures folder and save it. 
4. Return to your HCK2 file 
5. Click where you want the animated GIF to be inserted into your document 

and choose Insert  -> Image/File and select the file from 
your computer.  This will insert it to your home page 
and will sometimes display it using a generic icon 

like this - .  You can view your page in a 
Web Browser, and if necessary, use the resizing and 
text wrapping features of the FirstClass Client 
accordingly by clicking the image and adjusting the 
size.  

 
Creating Linked Pages 
Creating Linked pages is as simple as double-clicking on your stationery 
Template page, changing the page link name from New Document and 
adding content. 
If your template page is kept up to date, then all of the links and color schemes will 
be the same for your entire site.  This will give your web site a professional look and 
feel. 
The new file will open automatically with the name "New Document".  Change the 
name of the file to the name that you have entered in one of your Link Path fields on 
your Home Page.  There must be a corresponding file or link for each of your link 
fields. 
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Advanced Content Tips 
For the most part, the FirstClass Client will handle almost any kind of display that 
you wish.  However, there are some restrictions.  For example, there are no table 
features in FirstClass yet and the Tabs, though they work fine in the Client, do not 
render out content to the web in the same way.  You have two options here.  One is 
to use a graphic to display tabular text and the other is to use Literal HTML to display 
a true web table. 
 
Tables 
Tables may be added to place text 
and graphics in rows and columns. 
Select Table from the Insert menu 
above the body of the web page. 
 
 
 
 
 
 
 
 
Using a Literal HTML  
If you have access to an HTML editor, or if you 
are comfortable in HTML, you can design most 
any web content  in HTML.  Design your content 
so that it will appear the way you want it to 
and then view the corresponding source code.  
Copy everything including and between the < > 
and </ > tags. 
 
Once pasted in to your Home Page document, 
select all of the HTML text and choose Format -
> Style -> Literal HTML. 
This tells the web browser NOT to display it as 
text, but to interpret and display it as literal 
html. 
This goes for ANY code that you may wish to 
display, and not just tables. 
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Adding Sound Files 

Here are instructions on how to add an audio file to your FirstClass Web page that 
can be easily turned off by the viewer. It will look like this... 

  
Copy the three line text below, beginning with the <! and ending with the --> 

<!--Begin audio insert--> 

<p><embed height="44" src="images/BearSong.mp3" width="184"></p> 

<!--end audio insert--> 
1. Paste it into your web page where you want the control bar to appear. 
2. Replace the "images/BearSong.mp3" with the folder and file name of your audio 
file. The audio file must be in your home page folder. The one illustrated above is 
also inside a folder called “images.” 
3. Highlight the section 
4. Select the Format menu  
5. Select Format Text  
6. Check Literal HTML 
7. click OK 
Finish your web page. 
 
Links Within Content 
You are not restricted to having links only in the navigation section of your Home 
Page Construction Kit pages.  The content section of your home pages can also 
contain links. 
 
Text Links to Outside URLs 
To create a text link, type in some text and highlight (select) the text. 
Choose Edit -> Make Link to bring up the Link Dialog Box 
 
Text Links to Documents or Files in your Home Page Folder 
You can follow the above procedure to create a link to a document or File that 
resides in your Home Page folder but you can also just drag the file on to your 
content window and the link will be automatically created.  
 
Links Behind Embedded Graphics 
Links can be associated with embedded graphics as well. Just click on the image and 
choose Edit -> Make Link to bring up the Link Dialog Box. 
 
Graphics Software 
There are many different graphics software packages that you can use to assist you 
with manipulating graphics files.  This section will refer to Paint which is free and 
powerful enough to assist you in creating your Banner Image and to determine the 
pixel size and width.  

Go to Start> Programs> Accessories>  
 
The reliable, free and installed Paint application is feature rich enough to complete 
the task. Paint allows you to save graphics in a variety of different formats and to 
crop, resize and determine the pixel depth. 
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Cropping your Image in Paint 
To crop your image in Paint, place 
your mouse over one of the little 
squares (handles) that are placed 
around the image and drag until you 
get the size you want.  Repeat this in 
all directions until you get the size you 
want. 
 
 
---------- 

Determining the Pixel Width and Depth 
Once you have the image cropped to the size you want, choose Attributes from the 
Image Menu 

 
Make sure that you select Pixels as your Unit 
type and record the Width and Height 
dimensions. 
 

Saving Your Image 
Choose Save As... and select the correct 
file format to save your image to your 
computer for future uploading to your 
Home Page folder. 
 
 

 
 
 
 
 
 
 
To learn more than you want to know 
about creating your home page in the 
FirstClass HCK environment, open the 
Home Page Construction Kit inside the 
HCK folder. 
 

 
You may also visit http://www.burlesonisd.net/it/resources.htm for 
online help creating your web page.  
 
 


