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Introduction

Introduction

Many different types of graphics can be placed in presentations. You can import your own 
graphic files, choose ready-made graphics from the Impress Gallery or create your own 
graphics using the drawing tools available in Impress.

This chapter describes how to insert a graphic object into a presentation and how to format it. 
It focuses on the most commonly used graphics and formatting and provides useful tips to 
obtain a professional looking presentation in a short time.

Impress contains a number of advanced drawing functionalities that are rarely used when 
creating a presentation and are not fully described in this book. To create more advanced 
graphic objects, the reader is invited to use OpenOffice.org Draw and then to import the 
graphic object created there into an Impress slide. See the Draw Guide for more details.

Inserting pictures

This section describes several ways to insert a picture from an external source into the 
presentation. Once the picture has been inserted, it can be formatted extensively as explained 
later in this chapter.

Inserting a picture from a file
Inserting a graphic from a file is quick and easy. If the layout of the slide already contains a 
placeholder for a graphic (see Figure 1), double-click anywhere in the graphics frame. This 
opens a dialog for selecting the file to be inserted. The detailed procedure is given below. 

Figure 1: Slide with automatic layout including a placeholder for graphic object
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Inserting pictures

Whether you are using an AutoLayout for the placement of the picture, or you are just 
inserting a picture, follow these steps:

1) Select Insert > Picture. (When using an AutoLayout; double-click in the graphics 
frame instead.)

2) In the Insert Picture dialog (Figure 2), browse to the directory containing the desired 
graphic.

3) Select the file. OOo recognizes a very large number of image types.

4) Click Open to place the graphic on the current (selected) slide. The graphic object is 
now displayed on the slide with green resizing handles around it.

Figure 2: Inserting a graphic object from a file

Notice in the Insert picture dialog (Figure 2) the two checkboxes called Link and Preview. 
Their position is determined by the operating system, but they are normally in the bottom part 
of the dialog.

If Preview is checked, and if the selected file is in one of the many formats that OOo 
recognizes, a thumbnail of the selected image shows in the preview area on the right.

Select the Link checkbox to insert the picture as a link to the file rather than embedding the 
file itself. In general it is preferable to embed images so that the presentation can be copied to 
other computers, however on some occasions it makes sense to link the image rather than 
embed it:

• When the image file is quite large (linking rather than embedding will dramatically 
reduce the size of the presentation file)

• When the same image file is used in many presentations (for example when using the 
same background image for all the presentations created)

• When the linked file will be available when loading the presentation (for example if 
the presentation is a slide show of holidays pictures)
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Using a scanner
Importing an image from a scanner is normally fairly straightforward. Make sure that the 
scanner supports the SANE system and is already configured on the machine on which OOo 
is running. In case more than one scanner or equivalent device are present, select the source 
from Insert > Picture > Scan > Select Source.

To insert an image from the scanner:

1) Prepare the image in the scanner and make sure that the scanner is ready.

2) Select Insert > Picture > Scan > Request.

3) The rest of the procedure depends on the scanner driver and interface. You will 
normally be required to specify the resolution, a scan window and other parameters.

4) When the image is ready, Impress places it in the slide. At this point it can be edited as 
a normal image.

Inserting a picture from the Gallery
The Gallery contains a collection of images that you can use in a presentation. You can also 
add your own images to the Gallery, making it an essential tool for creating presentations 
quickly and with a consistent look. The Gallery is available in all components of 
OpenOffice.org. For an introduction to the Gallery, see Chapter 14, “Working with the 
Gallery” in the Getting Started guide.

Select Tools > Gallery or click the Gallery icon  on the Drawing toolbar. 

By default, the Gallery (shown in Figure 3) is docked above the Impress workspace. To 
expand the Gallery, position the pointer over the line that divides it from the top of the 
workspace. When the pointer changes to parallel lines with arrows, click and drag downward. 
The workspace will resize in response.

Figure 3: The Gallery – needs labels, including Hide/Show button, others
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To expand the Gallery without affecting the Impress workspace, undock it so it floats over 
the workspace. To do so, hold down the Control key and double-click on the upper part of the 
Gallery next to the View icons (see Figure 3). Double-click in the same area to dock it again 
(restore it to its position over the workspace).

When the Gallery is docked, to hide it and view the full Impress workspace, click the 
Hide/Show button in the middle of the thin bar separating the Gallery from the workspace 
(see Figure 3). The Hide/Show button lets you keep the Gallery open for quick access while 
you create your slide show, yet out of the way when you need it to be. Additional information 
on the use of the Gallery can be found in “Managing the Gallery themes” on page 13.

Formatting pictures

This section discusses the formatting of images inserted with one of the methods explained in 
“Inserting pictures” on page 1. The graphic objects in this section may be referred to as 
pictures, images or graphics.

Moving graphic objects
1) Click the graphic object, if necessary, to show the green resizing handles.

2) Move the pointer over the graphic object until the pointer changes shape. On most 
operating systems, the cursor associated with moving objects is a four headed arrow, 
but it may also be a hand or some other symbol.

3) Click and drag the graphic object to the desired position.

4) Release the mouse button.

For a more accurate placement of the graphic object, use the Position and Size dialog shown 
in Figure 4. To open this dialog, first select the graphic object by clicking on it; when the 
resizing green handles are displayed, either press F4 or select Format > Position and Size 
from the menu bar.

Use the Position section of the dialog to specify the X (horizontal) and Y (vertical) position 
of the graphic object. The values represent the distance of the base point (selected  on the 
right hand side of the dialog) relative to the top left corner of the slide.

To prevent accidental modification of the position of the graphic object, select the Position 
checkbox in the bottom left part of the dialog.

The unit of measurement for this and the other dialogs in this section is set in Tools > 
Options > OpenOffice.org Impress > General.
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Formatting pictures

Figure 4: Fine adjustment of position and size of the graphic object

Resizing graphic objects
1) Click the graphic object, if necessary, to show the green resizing handles.

2) Position the pointer over one of the green resizing handles. The pointer changes shape 
giving a graphical representation of the direction of the resizing.

3) Click and drag to resize the graphic object.

4) Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the graphic object simultaneously, 
while the other four handles only resize one dimension at a time.

Tip To retain the original proportions of the graphic, Shift+click one of the corner 
handles, then drag. Be sure to release the mouse button before releasing the Shift key.

For more accurate resizing of the graphic object, use the Position and Size dialog (Figure 4). 
Select as the base point the part of the graphic object that you would like to anchor to the 
page. The default setting (top left corner) means that the when resizing the area, the position 
of the top left corner of the area will not change. Now modify either the Width value or the 
Height value of the object. To maintain the proportions between width and height, select the 
Keep ratio checkbox before modifying any value. Notice that when the checkbox is selected 
both dimensions change simultaneously.

To prevent accidental modifications of the size, make sure that the Size checkbox is selected 
in the Protect section in the bottom left part of the dialog.
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Rotating graphic objects
As for the position and the size, rotation of an object can be done manually or using a 
dedicated dialog. To rotate a graphic manually, do as follows:

1) Select the graphic object if necessary so that the green handles around it show.

2) Click the Rotate button  on the Drawing toolbar. This toolbar is usually located at 
the bottom the screen, but it can be undocked and used as a floating toolbar. If the 
toolbar is not showing, select View > Toolbars > Drawing. The Drawing toolbar is 
discussed in detail in Chapter xx.

Note The icons representing the functions in the toolbars are different depending on the 
operating system used and on whether OOo has been customized for the Linux 
distribution in use or not. When in doubt, hover the mouse over the icons and wait 
for the tooltip to appear showing the name of the button.

3) Eight red handles replace the green square handles, as shown in Figure 5. Move the 
mouse over one of the corner handles and the mouse cursor shape will change. Click 
the mouse and move in the direction in which you want to rotate the graphic object.

4) When satisfied release the mouse button.

Figure 5: Shape showing the red rotating 
handles. Only the corner ones are active.

At step 2 a black crosshair with a circle appears in the middle of the picture: this represents 
the pivot point for the rotation. Normally the center of the picture will be just fine, but on 
some occasions you may wish to rotate around a corner or even around a point outside the 
picture; to do that, click on the crosshair and drag it to the desired position.

To restrict the rotation angles to multiples of 15 degrees, press the Shift key while rotating the 
graphic. This is very handy to rotate pictures of right angles, for example from portrait to 
landscape or vice versa.

Instead of rotating a graphic object manually, you can use the Rotation dialog shown in 
Figure 6. To display this dialog, select the graphic object so that the green resizing handles 
are shown, then press F4 or select Format > Position and Size and select the Rotation tab.
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Figure 6: The Rotation page of the Position and Size dialog

In the top part of the dialog, select the position of the pivot point relative to the top left corner 
of the page. The default position of the pivot point is the center of the figure.

In the lower part of the dialog select the angle by which to rotate the graphic object. On the 
right hand side 8 default rotation values are easily configurable by selecting the desired 
button.

Formatting using the picture toolbar
When a picture is selected, the Picture toolbar (Figure 7) becomes available. This toolbar 
provides a number of formatting options which are described in this section. If the picture 
toolbar does not show when an image is selected, display it by selecting View > Toolbars > 
Picture from the menu bar.

Figure 7: The Picture toolbar

Applying filters

Use the left-most icon on the toolbar to apply various filters to the selected picture. The best 
way to judge if a filter works for your picture is to try it. To apply a filter:

1) Select the image so that the green handles around it show.
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2) Click on the magic wand icon  in the Picture toolbar. The toolbar will expand to 
show the icons in Figure 8.

Figure 8: The graphic filters 
available in Impress

3) Select the filter to apply. To show the name of the filter, hover the mouse over the icon 
and wait for the tooltip to appear.

If not satisfied with the effect obtained, before doing anything else select Edit > Undo: 
Bitmap Graphic Filter from the menu bar or press Control+Z. 

Table 1 describes briefly each of the available graphic filters and their effects. See the Draw 
Guide for examples of the effects.
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Table 1: Graphic filters and their effects

Icon Name Effect

Invert Inverts the color values of a color image, or the brightness 
values of a grayscale image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove 
noise

Removes single pixels from an image.

Solarization Mimics the effects of too much light in a picture. A further 
dialog opens to adjust the parameters.

Aging Simulates the effects of time on a picture. Can be applied several 
times. A further dialog will open to adjust the aging level.

Posterize Makes a picture appear like a painting by reducing the number 
of colors used.

Pop Art Modifies the picture dramatically.

Charcoal Displays the image as a charcoal sketch.

Relief A dialog is displayed to adjust the light source that on turn will 
create the shadow and hence the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Changing the Graphics mode

Use the next box in the Picture toolbar to change the mode of the image. Choose between:

• Default: no changes to the graphic object.

• Grayscale: the image is converted to scales of gray.

• Black/White: each pixel of the image is converted to black or white depending on the 
brightness value.

• Watermark: adjusts the brightness of the image making it suitable to be used as a 
watermark. For more information on creating watermarks, refer to Chapter 2.

Adjusting the graphics color

Clicking the color adjustment button  of the Picture toolbar opens the color adjustment 
dialog, shown in Figure 9.
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Figure 9: The color adjustment dialog

Use this dialog to modify the individual color components of the image (red, green, blue) as 
well as the brightness, contrast, and gamma of the image.

Setting the object transparency

Modify the percentage value in the Transparency box  on the Picture toolbar 
to make the image more transparent. Note that this is different from the transparency settings 
for a line or a shape.

Adjusting the line, area and shadow settings

These settings are not very commonly used for images with the exception of the shadow 
setting that applies a shadow to the image.

Cropping graphics

To start cropping a picture, select the Crop icon  from the Picture toolbar (Figure 7).

Figure 10: The options available when cropping a picture
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The Crop dialog (Figure 10) has the following options:

• Keep scale / Keep image size buttons: when Keep scale is selected (default), cropping 
the image does not alter the scale of the graphic. When Keep image size is selected, 
cropping produce enlargement (for positive cropping values), shrinking (for negative 
cropping values), or distortion of the image so that the image size remains constant.

• Left, Right, Top, and Bottom: the function of these boxes changes according to the 
choice made between Keep scale and Keep image size. In both cases, when a value is 
entered in one of these boxes, the image is cropped by that amount. For example, a 
value of 3cm in the Left box will cut 3cm from the left side of the picture.

When Keep scale is selected, the size of the image also changes, so in this example the 
width will be reduced by 3 cm. If Keep image size is selected instead, the remaining 
part of the image is enlarged (positive values for cropping) or shrunk (negative values 
for cropping) so that the width and height of the image remains unchanged.

Note that the Width and Height fields change as you enter the values when in this 
mode. Use the thumbnail next to these fields to determine the correct amount by which 
to crop.

• Scale Width and Height: specify in percentages the scaling of the graphic object. The 
size of the image changes accordingly.

• Image size: specify the size of the image in your preferred unit of measurement. The 
image enlarges or shrinks accordingly.

• Original size: when clicked, restores the original image size.

Deleting graphic objects
1) Click the graphic object, if necessary, to show the green resizing handles.

2) Press Delete.

Creating an image map

An image map defines areas of the image (called hotspots) with a URI (a web address or a 
file on the computer). Hotspots are the graphic equivalent of text hyperlinks. Clicking on a 
hotspot causes Impress to open the linked page in the appropriate program (for example, the 
default browser for an HTML page; OOo Writer for a .ODT file; a PDF viewer for a PDF 
file). You can create hotspots of various shapes, and include several hotspots in the same 
image. See the Draw Guide for more details on the creation and use of imagemaps.

To use the image map tool:

1) Select the picture where the hotspots will be defined.

2) Choose Edit > ImageMap from the menu bar. The ImageMap Editor dialog (Figure
11) opens.

3) Use the tools and fields in the dialog to define the hotspots and links necessary.
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Creating an image map

4) Click the Apply icon  to apply the settings.

5) When done, click the Save icon  to save the imagemap to a file, then click the X in 
the upper right corner to close the dialog.

Figure 11: The dialog to create image maps. The last ‘o’ of the word Authors is set as an 
active hotspot

The top part of the dialog contains the following tools:

• Apply button: click this button to apply the changes.

• Load, Save, and Select icons.

• Tools for drawing a hotspot shape: these tools work in exactly the same way as the 
corresponding tools in the Drawing toolbar.

• Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of 
a polygon hotspot. Select the Edit Points tool to activate the other tools.

• Active icon: activates the selected hotspot or deactivates it.

• Macro: associates a macro with the hotspot instead of just following the hyperlink.

• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:

• Address: the address pointed by the hyperlink. You can also point to an anchor in a 
document such as a specific slide number; to do this, write the address in this format: 
file:///<path>/document_name#anchor_name
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Creating an image map

• Text: enter the text that will be displayed when the mouse is moved over the hotspot.

• Frame: where the target of the hyperlink will open: pick among _blank (opens in a 
new browser window), _self (opens in the active browser window), _top or _parent.

Tip The value _self for the target frame will work just fine in the vast majority of the 
occasions. It is therefore not recommended to use the other values unless absolutely 
necessary.

The main part of the dialog shows the image on which the hotspots will be defined and the 
hotspot itself. Note that an active hotspot is indicated by a white shading, while an inactive 
hotspot is identified by a red border but no shading.

Managing the Gallery themes

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and 3D Effects. The 
box on the left of the gallery window lists the available themes. Click on a theme to see its 
graphics displayed in the Gallery window (see Figure 3).

The default themes are locked; no items can be added or deleted from these themes. The 
locked themes are easily recognizable by right-clicking on them; the only available option in 
the pop-up menu is Properties.

In a default installation, only the My themes theme is customizable, although new themes can 
be added as explained in “Adding a new theme to the Gallery” on page 14.

Adding graphics to the Gallery
You can add new graphic files to existing themes which you created or that can be edited. 
There are several ways to add a file to an existing theme.

Method 1 (selecting a file):

1) Right-click on the theme name in the list of themes and choose Properties from the 
pop-up menu.

2) Click the Files tab, if necessary.

3) Click Add.

4) Select a file and click Open. The file is added to the theme.

Method 2 (drag and drop):

1) Open the document containing a graphic you want to add to the Gallery, and display 
the Gallery theme you want to add the graphic to.

2) Click on the image with the left mouse button and, holding the button pressed, drag 
the image into the document.

3) Release the mouse button.

Figure 12 shows an example of an image dragged from the Gallery.
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Figure 12. Inserting an image from the Gallery

Deleting graphics from the Gallery
To delete a graphic from a theme:

1) Right-click on the graphic in the Gallery window.

2) Choose Delete from the pop-up menu. A message appears, asking if you want to delete 
this object.

3) Click Yes. The graphic is deleted from the theme.

Note The graphic is deleted from the Gallery only. The original graphic file is not deleted.

All the images in a gallery are actually linked files. From time to time it is beneficial to 
update the gallery theme to make sure that all the files are still there. To do so, right-click n 
the theme where you added at least one file and then select Update from the pop-up menu.

Adding a new theme to the Gallery
1) Click the New Theme button above the list of themes (see Figure 3).

2) Click the General tab and type a name for the new theme.

3) Click the Files tab (Figure 13).
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Managing the Gallery themes

Figure 13. Setting up a new theme in the Gallery  

4) Click Find Files. The Select Path dialog opens. Browse to the folder that contains the 
files for the new theme and click OK.

  Figure 14. Choosing files to add to the new theme

5) Back on the Files tab, use File Type and/or select a file from the list displayed, to 
choose to add a file or all files. (See Figure 13.)

6) Click OK when finished.
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Note The files do not show in the large box under the File Type box; and under the 
General tab, the Contents will display as “0 Objects,” but the chosen files will be 
inserted into the new theme. Remember, you can always add or delete graphic files 
later.
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