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DRAFT Introduction

Introduction

This chapter describes how to create your own graphics using the drawing tools available in
Impress. It focuses on the most commonly used tools and techniques.

Impress also contains a number of advanced drawing functions that are rarely used when
creating a presentation and are not fully described in this book. To create more advanced
graphic objects, the reader is invited to use OpenOffice.org Draw and then to import the
graphic object created there into an Impress slide. See the Draw Guide for more details.

The Drawing toolbar

The Drawing toolbar contains the tools used to create rectangles, circles, and other lines and
shapes to enhance the design of the presentation. If this toolbar is not showing, select View >
Toolbars > Drawing from the main menu bar.

1 23 45 6 7 8 9 10 11 12 13 14 15
I

1
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1 Select 4 Rectangle 7 Vertical Text 10 Basic Shapes 13 Flowcharts
2 Line 5 Ellipse 8 Curve 11 Symbol Shapes 14 Callouts
3 Arrow 6 Text 9 Connector 12 Block Arrows 15 Stars

Figure 1: First section of Drawing toolbar with drawing objects tools

The toolbar can be divided into two parts. The first part contains drawing objects, as shown
in Figure 1. The tools in this part of the drawing toolbar are:

+ Select: selects objects.

+ Line: draws a straight line.

+ Line ends with arrow: draws a straight line ending with an arrowhead.
- Rectangle: draws a rectangle. Press the Shift button to draw a square.

- Ellipse: draws an ellipse. Press the Shift button to draw a circle.

- Text: creates a text box with text aligned horizontally.

- Vertical text: creates a text box with text aligned vertically. This tool is available only
when Asian language support has been enabled in Tools > Options > Language
Settings > Languages.

+ Curve: draws a curve. Click the black triangle for more options, shown in Figure 2.
The title of the submenu is incorrectly shown as Lines.

Working with Lines and Shapes 1



DRAFT The Drawing toolbar
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Figure 2: Available curve options

- Connectors: draws a connector line between two figures. Click the black triangle for
additional connectors, shown in Figure 3.

Conn.,.. = X

T L "L
NN
NN
= a3

Figure 3: Connectors options

- Basic Shapes, Symbol Shapes, Block Arrows, Flowcharts, Callouts, Stars: click
the black triangle to open a toolbar showing the available shapes in that category. The
default shapes available in Impress are shown in Figure 4. Select the desired shape,
then draw the shape as normal. Keep the Shift key pressed to obtain a shape where the
height and width are equal.
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Figure 4: Available shapes for Impress
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The Drawing toolbar

The second part of the toolbar, shown in Figure 5, contains more generic tools.

1 2 i 4 &5 B 7 g 3 10 Nn
T O R R e e
(=, & E ma Cr bl - LT - )
1 Edit Points 4 From File 7 Alignment 10 Interaction
2 Glue Points 5 Gallery 8 Arrange 11 Visible Buttons

3 Fontwork 6 Rotate 9 Extrusion ON/Off
Figure 5: The second section of the drawing toolbar with utility tools

Those

tools are:

Edit points: select this tool, then select a shape or a line, to edit the individual points
that form the shape or line.

Glue points: select this tool to edit the glue points of a graphic object. Glue points are
the positions where connector lines terminate or start. See “Managing glue points” on
page 25 for instructions.

Fontwork: opens the Fontworks gallery. See “Using Fontwork™ on page 20 for further
information.

From file: equivalent to Insert > Picture > From file on the main menu. See Chapter
4 for details.

Gallery: opens the gallery. Equivalent to Tools > Gallery on the main menu. See
Chapter 4 for details.

Rotate: select this tool to rotate an object. See “Rotating graphic objects” in Chapter 4
(Working with Pictures and Other Graphics) for details.

Align object: see “Aligning shapes* on page 17.
Arrange object: see “Arranging shapes on page 16.

Extrusion On/Off: switches 3D effects on or off for the selected object. Clicking this
button also opens the 3D settings toolbar. See “Working with 3D shapes” on page 30
for details.

Interaction: opens a dialog where you can specify the interaction between the user
and the object. See “Setting up interaction with a shape or image” on page 26.

Working with Lines and Shapes 3
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Creating lines and shapes

To create shapes and lines: L D
1) Select the desired line or shape tool.

2) Click and drag to create the object on the slide. See
Figure 6.

When drawing a polygon, keep the Shift key pressed to \A
restrict the angle between the segments to multiples of 45
degrees. To finish drawing a polygon, double-click on the
last part of the segment. If a closed polygon was selected,
OO0 will color the inside area.

Figure 6: Creating a shape

When drawing certain shapes, one or more yellow dots are displayed along with the blue
resizing handles. These dots perform a different function according to the shape they are
applied to. With the basic shapes the yellow dot (or dots) are used for the following purposes:

Rounded rectangle and Rounded square shapes: use the yellow dot to change the size
of the curve replacing the corners.

Circle Pie: use the two yellow dots to change the size of the filled sector.
Isosceles triangle: move the yellow dot on one vertex to modify the triangle type.

Trapezoid, Parallelogram, or Octagon: move the yellow dot to change the angle
between the sides.

Cross: use the yellow dot to change the thickness of the four sides.
Ring: use the yellow dot to change the internal diameter.

Block arc: use the yellow dot to change both the internal diameter and the size of the
filled area.

Cylinder and Cube: use the yellow dot to change the perspective.
Folded corner: use the yellow dot to change the size of the corner.

Frame: use the yellow dot to change the internal rectangle diagonal.

Formatting lines and shapes

Use the Format menu to modify lines and shapes.
1) Click on the shape or line to select it.

2) Click Format in the main menu. Some of the options may not be available (grayed
out) because of the type of object selected. For example, if the object is a simple line,
the Area choice will be unavailable because a line does not have an area to fill.

3) Select one of the formatting options:

Line to set the characteristics of the line, including the border of an area.

Working with Lines and Shapes 4
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« Area to format the fill, or interior, of an object. This includes color, transparency,

and pattern.

- Position and Size allows an object to be moved, rotated, and manipulated

Formatting lines and shapes

according to specified measurements.

« Text to format the appearance of the text that can be added to any shape or line.

The following sections provide details of the available options for each of these formatting

parts.

Formatting lines

The dialog to format the line properties is shown in Figure 7. It contains three pages.

Line properties

“
Line | Line Styles | Arrow Styles |

Arrow styles

Style Style
e Continuous - none - * | -none -
Color Width
Il Elack 0.30cm = 0.30cm
Width Center Center
0.00cm 2 Synchronize ends
Transparency Corner style
0% 2 Style

Rounded s

¥ ook Cancel Help

Figure 7: Main line formatting dialog

The Line page is further subdivided into four parts handling different aspects of the line.

The Line Properties section (left side) is the most important. It includes the following

parameters:

- Line style: a variety of line styles is available in the drop-down list, but more can be
defined if needed (see Appendix B for details on how to create new line styles).

+ Color: pick among the already defined colors. If a color not in the list is needed, refer
to Appendix B to create a new one.

«  Width: specifies the thickness of the line.

Working with Lines and Shapes
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- Transparency: sets the transparency value of the line, a useful property when you do
not want to hide completely what is under the line.

The Arrow styles section of this page is only applicable to line segments; it has no effect on
the line that forms the border of a shape or of a polygon. Use this section to set the styles of
the two ends of the segment. You can configure independently the two ends, selecting for
each of them the arrow shape (Style drop-down menu), the Width, and the termination style
(Center checkbox). Selecting the Center checkbox moves the center of the arrowheads to
the end point of the line. If the two ends should be identical, select the Synchronize ends
checkbox. To create new arrowheads, use the Arrow styles page, as described in Appendix B.

Use the Corner style section of this page to choose how the connection between two
segments should look. There are four available options in the drop-down menu.

The bottom part of the page shows a preview of the applied style and a preview of two
corners so that the corner style choice can be quickly evaluated. To appreciate the difference
between corner styles, choose a thick line style and observe how the preview changes.

Formatting areas

Impress offers many different options for formatting the fill of an area.
1) Start by selecting the object to which the formatting will be applied.

2) When the resizing handles appear, select Format > Area from the menu bar. The
dialog shown in Figure 8 is displayed.

Area Shadow | Transparency | Colors | Gradients | Hatching | Bitmaps

Fill

coor—————___[E
ClGay A

[ ] Light gray
B Light blue B
[ Light green
[ Light cyan

I Light red

B Light magenta
] vellow

1 white

Il Gray 80%

Bl Gray 70%

B Gray 60% [ -]

¥ ook ‘ Cancel Help Reset

Figure 8: Area page of the area formatting dialog
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3) Select the desired type of fill from the drop-down list. The Area page changes to
display the choices available for that fill style, as described on the following pages.

4) Select the required fill and its parameters, and then click OK to close the dialog and
apply your selection.

Picking the type of fill from the four choices (None, Color, Gradient, Hatching, and Bitmap)
modifies the entries in the list below and makes some new options appear in the Area tab.
The list is populated with the default choices for the selected fill type. If none of the choices
is satisfactory, you can fully customize the fill by using the tab with the corresponding name
in the same dialog. Appendix B describes how to create new fills.

Colors

For color fills, select one from the list, as shown in Figure 8.

Gradients

A gradient fill provides a smooth transition from one color to another. The transition pattern
may vary from a simple linear transition to a more complex radial transition.

If the predefined gradients are not satisfactory, you can create a new gradient or modify an
existing one. See Appendix B.

Select Gradient in the drop-down list on the Area page and pick the gradient from the list
(see Figure 9). To manually input the number of steps (increments) that should be applied,
deselect the Automatic checkbox and enter the number of steps required.

= Ara ™

|Area| Shadow] Transparency ] Colors] Gradients ] Hatching] Bitmaps]
Fill Increments

[Gradient B < Automatic 64

[P Gradient 1

Il Gradient 2

[l Gradient 3

[ ] Gradient 4

Il Gradient 5

I Gradient 6

] Linear blue/white
Il Radial green/black
[ Rectangular redf/white L
[ ] Square yellow/white

[ Linear magenta/green

[ Linear yellow/brown =

[ oK HCanceI H Help H Reset l

Figure 9: Selecting a gradient fill
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Hatching
A hatching fill is a pattern of lines that is repeated throughout the area.

To apply a hatching pattern to an area, go to the Area page, select Hatching from the
drop-down list and then select the desired hatching from the list (Figure 10). To apply a
background color to the hatching pattern, selecting the Background color checkbox and
choose a color from the drop-down list.

As for gradients and colors, if the predefined patterns are not satisfactory, you can create a
new pattern or modify a predefined one. See Appendix B.

|'- = Area |

|Area| Shadow] Transparency ] Colors] Gradients ] Hatching] Bitmaps]

Fill +|Background color:

'Hatching : ] IBlue 8 s

E= Black 0 degrees

Black 45 degrees

Black -45 degrees

[T Black 20 degrees

Red crossed 45 degrees
Red crossed 0 degrees
Blue crossed 45 degrees
Blue crossed 0 degrees
Blue triple 90 degrees
Black 45 degrees wide

OK [ Cancel ] [ Help l [ Reset

Figure 10: Selecting a hatching fill pattern

Bitmaps
The last type of fill for an area is the bitmap fill.

On the Area page, chose Bitmap from the drop-down list. Select from the list of bitmaps the
one to be used to fill the area. Note that any imported bitmaps should be available in the list.

Set the size, position and offset parameters (as applicable) in the right hand side of the tab,
and then click OK to close the dialog.

As Figure 11 shows, when using a bitmap fill there are quite a number of parameters to be
configured. These are described in Table 1.

As for the other types of fill, OOo comes with a number of predefined bitmaps, but you can
also add new ones or to create your own pattern. See Appendix B.

Working with Lines and Shapes 8
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Formatting areas

Fill
Bitmap

BB Gravel

= Wall
Brownstone
S netting
SRl | eaves
B Artificial Turf
“ Daisy

Bl Orange
"o Fiery

B roses

EX¥ OOoAuthorsLogo

_‘ﬂi_x
Area| Shadow | Transparency | Colors | Gradients | Hatching | Bitmaps |

_~0tsAuthors

Size
i Crigina Width 100% =
o v Relative Height |100% -
Position
| |
- &
L~ 4
¥ Offset 5% -
¥ Offset 0% =
v Tile v
Offset
Row
Column 0% =
F ok Cancel Help Reset

Figure 11: Advanced formatting for bitmap fill

Table 1: Bitmap fill properties

Property Meaning

Size — Original

Select this box to retain the original size of the bitmap.

Size — Relative

To rescale the object deselect the Original checkbox and
select this one. The Width and Height edit boxes are
enabled.

Size — Width

When Relative is selected 100% means that the bitmap
original width will be resized to occupy the whole fill area
width, 50% means that the width of the bitmap will be half
that of the fill area.

Size — Height

When Relative is selected 100% means that the bitmap
original height will be resized to occupy the whole fill area
height, 50% means that the height of the bitmap will be half
that of the fill area.

Position — Anchor Map

Select from the map the place of the area where the bitmap
should be anchored to.

Position — X offset

When tiling is enabled, enter in this box the offset for the
width of the bitmap in percentage values. 50% offset means
that at the anchor point of the bitmap OOo will place the
middle part of the bitmap and start tiling from there.

Working with Lines and Shapes
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Property Meaning

Position — Y offset

Formatting areas

This will have the same effect of the X offset, but will work
on the height of the bitmap.

Position — Tile

When this checkbox is selected the bitmap will be tiled to
fill the area. The size of the bitmap used for the tiling is
determined by the Size settings.

Position — Autofit

Stretches the bitmap to fill the whole area. Selecting this
checkbox disables all the size settings.

Offset — Row

If tiling is enabled offsets the rows of tiled bitmaps by the
percentage entered in the box so that two subsequent rows
are not aligned.

Offset — Column

If tiling is enabled, offsets the columns of tiled bitmaps by
the percentae entered in the box so that two subsequent
columns of bitmaps are not aligned.

The way some of these parameters work is difficult to describe; the best way to understand
them is to use them. Some examples of bitmap fills are given in Figure 12 along with the

parameters used.

. — - original bitmap

/1 Original size
_ e 'voanchor to left
10 Authers 1 'L th I carner
'+ no offset
J T Authers ; J T Auth .
J T Authers ; Jo T Auth .
~  + Original size
/ i+ anchor middle
— _ ' v 30% column offset
s Authors -~ !
hors = :
iricAuthars |
hors = |
st Authars
//—: * Relative size
! 35% width, 25%
siTuthors < udTluthors < dAutho ' height
1« anchor to top left
yiThuthors . udTRuthors < U TAutho \ - corner
'« nio offset
Jiuthors . udTutaees < ot :
Jiiuthors < udTutaoes < ot !

Figure 12: Some examples of bitmap fill

Working with Lines and Shapes
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Formatting shadows

Shadowing can be applied to both lines and areas. To apply a shadow to an area, first select
the object to which shadowing should be applied, then press Format > Area.

Shadows can also be applied to lines, but it is not very obvious how to do it. One way is to
click the Shadow icon on the Line and Filling toolbar (see the last tool in Figure 13). The
other way is to apply a style to the line that uses a shadow (see “Using Graphic styles to
format graphics” on page 19 for additional information on using styles).

Line and Filling > X
E O % - — |: |oooecm i EMBlack 2| & color * [1Blue s il
Figure 13: The Line and Filling toolbar allows quick access to many common formatting

tools

Using the first method, you cannot customize the shadow; it is applied according to the
default settings. The second method offers full flexibility to configure the shadow properties.
If the Line and Filling toolbar is not shown when selecting an object, open it using View >
Toolbars on the menu bar.

The dialog to customize a shadow is shown in Figure 14.

m
Area Shadow Transparency | Colors | Gradients | Hatching | Bitmaps |

Properties

Position ‘T o T
o~ o '
(_[_ |
Distance 0.10cm =
Color B Gray -
Transparency 40% -

¥ oK Cancel Help Reset

Figure 14: Dialog for customizing the shadowing of graphic objects

When the Use shadow checkbox is selected, the following parameters can be set:

- Position: the selected point in the mini map determines the direction in which the
shadow is cast.

Working with Lines and Shapes 11
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- Distance: determines the distance between the object and the shadow.
« Color: sets the color of the shadow.

« Transparency: determines the amount of transparency for the shadow.

Tip By setting the transparency value above 0%, the objects below the shadow are not
completely hidden by the shadow. This produces a pleasant visual effect, as shown
in Figure 15.

Figure 15: Shadow with 50% transparency

Transparency formatting

Transparency is applicable to lines, areas, and shadows. To apply transparency to lines, refer
to “Formatting lines” on page 5; for shadows, refer to “Formatting shadows” on page 11.

To apply transparency to areas, select Format > Area and then go to the Transparency tab
shown in Figure 16.

Area | Shadow Transparency Colors | Gradients | Hatching | Bitmaps

Transparency mode
" [No transparency]

" Transparency 50% =

s Gradient

Type Linear | .
50% =
50% 5

Angle Im

Border 25% =

Start value 0% =

End value 100% -

¥ ook Cancel Help Reset

Figure 16: Setting the object transparency

Working with Lines and Shapes 12



DRAFT Formatting areas

There are two types of transparency: one which is uniformly applied to all the area of the
object, and the gradient one. To obtain an uniform transparency select the Transparency
radio button and then select the percentage of transparency required. For a gradient
transparency so that the area becomes gradually transparent, select the Gradient radio button
and then set the parameters of the gradient:

Type: pick between Linear, Axial, Radial, Ellipsoid, Quadratic or Square.

Center X, Y: for some types of gradient, you can specify the position of the center in
percentage points.

Angle: the angle of the gradient, applicable to all but the radial type of gradients.

Border: the percentage of the shape (measured from the edge) that is not subject to the
gradient settings.

Start value: the transparency value of the start point of the gradient: 0% is fully
opaque, 100% means fully transparent.

End value: the transparency value of the end point of the gradient: 0% is fully opaque,
100% fully transparent.

Formatting text

Impress provides two separate dialogs related to text formatting.

To modify the formatting such as font, font effects and so on, select the text in the
shape and then go to Format > Character. This is covered in Chapter 3.

To determine how the text which is added to a line or a shape behaves, use the settings
on the Text dialog, as described in this section.

Before formatting text, add it to the object (a shape or a line):
1) Select the object to which text will be added.

2) With the green (or blue) resizing handles showing, double-click on the object and wait
for the cursor to become an I-beam or just start typing.

3) Type the text. When finished, click somewhere outside the object or press Esc.
To format the text in a shape:
1) Select the object to which text was added.

2) Select Format > Text or right-click on the shape and select Text from the pop-up
menu. The dialog of Figure 17 is displayed.

Working with Lines and Shapes 13
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m
Text TextAnimation |
Text
v v
Eit to frame
Adjust to contour
Spacing to borders Text anchor
Left 0.10cm = e
Right 0.10cm . l & i
Top 0.20cm = | |
' ' il
Bottom .20cm ; .
b Full width
¥ oK Cancel Help Reset

Figure 17: Main dialog to set the text properties
The top section of the dialog offers several options in the form of checkboxes. Some of the
checkboxes will be grayed out, depending on the object to which the text will be attached.

« Select Fit width to text to expand the width of the shape or line if the text is longer
than it.

+ Select Word wrap text in shape to automatically start a new line when the edge of
the shape is reached.

+ Select Fit height to text to expand the object height whenever it is smaller than the
text (set by default for lines.

- Select Resize shape to fit text to expand a custom shape when the text inserted in the
shape is too large.

- Select Fit to frame to expand the text so that it fills all the available space.
+ Select Adjust to contour to make the text follow a curved line.

In the Spacing to borders section, specify the amount of space to be left between the border
of the shape or line and the text; this is similar to the settings for indentation and spacing for
paragraphs.

The text anchor grid is used to decide where to anchor the text. The Full width checkbox
determines if the anchoring should be performed to the full width of the shape.

Working with Lines and Shapes 14
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Text animation

Use this tab to specify special effects applied to the text. Choose between four options in the
list and where applicable the direction of the effect picking one of the four arrow buttons to
the right. The available effects are:

- Blink: the text will blink on the screen.

« Scroll through: the text will move into the shape and then out following the chosen
direction.

+ Scroll back and forth: the text will not exit the shape border and move first in the
chosen direction.

+ Scroll in: the text will scroll in towards the given direction starting from the edge of
the shape.

By default no animation is applied.

The other properties that can be set are:
« Start inside checkbox: when set the animation will start from inside the shape.
- Text visible when editing checkbox: set this box to see the text while editing.

« Animation cycles: includes three further options to set the frequency of the animation,
the increments between two positions of the animation and finally the delay before the
animation starts.

To see some of the animations in action, it is necessary to start the presentation. Press F9 or
select Slide Show > Slide Show from the main menu. To return to the edit mode press the
Esc key.

Formatting connectors

Connectors are lines that join two shapes. Connectors stem from a glue point of the shape.
Refer to “Managing glue points” on page 25 for instructions.

For more about connectors and glue points, see the Draw Guide.
Use the dialog shown in Figure 18 to set the style of the connectors.

In the Connector dialog, set the type of connectors choosing between Line connector, Straight
connector and Curved connector. Whenever multiple connectors overlap, use the Line skew
section of the dialog to distance the lines. It is possible to customize the distance between 4
different lines.

In the Line spacing section of the dialog, set the space at the beginning and at the end of the
connector, both horizontally and vertically.
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= Connector X
Type Standard Connector s e oK
Line skew Cancel
Line 1 0.50cm =
Help

Line spacing

Begin horizontal 0.50cm =
Begin vertical 0.50cm =
End horizontal 0.50cm =
End vertical 0.50cm =

Figure 18: Setting up the connectors properties

Arranging shapes

Arrange determines the stacking order of the selected object. Impress organizes objects in a
stack so that the objects on a high level of the stack cover the objects on lower levels if
overlapping occurs. To modify the position of an object in the stack click the small triangle
on the side of the tool to open the extended toolbar of Figure 19 where seven options are
available. The same arrange options described below are available from the context menu.

Position * X

O0da &
8@ =
Figure 19: The extended Arrange toolbar
The first four work on a single object and they are:
- Bring to front: the selected object is moved on top of any other object.
« Bring forward: the selected object is moved one level up in the stack.
+ Send backwards: the selected object is moved one level down in the stack.
+ Send to back: the selected object is given the lowest position in the stack.
The other three tools work on the relative positions of two objects and they are:
- In front of object: brings the selected object in front of the second selected object.
- Behind object: brings the selected object behind the second selected object.

- Reverse: swaps the stacking order of two selected objects.
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To use the In front of object and Behind object tools:
1) Select the first object by clicking on it.
2) When the green handles show, select the desired arrange action.

3) The mouse pointer changes to a pointing hand. Click on the second object.

Aligning shapes

Use the Alignment tools to adjust the relative position of a graphic object compared to
another object. Clicking on the Alignment icon in the Drawing toolbar opens the extended
toolbar of Figure 20. The same alignment options are available from the right-click menu.

Align = x
= F =
m g 0o
Figure 20: The align extended toolbar

The toolbar has six icons. The first three determine the horizontal alignment of the selected
objects (Left, Center, Right); the other three determine the vertical alignment of the selected
objects (Top, Middle, Bottom). If only one object is selected, it is aligned to the page,
however when in a group, a single object is aligned to the edge of the group selection.

Flipping shapes

To flip an object or group, right-click on it and select either Flip > Vertically or Flip >
Horizontally. The object will be flipped around an imaginary axis (horizontal and vertical
respectively) passing through the center of the object, or group.
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Converting an object to a different type

This is an advanced menu that allows to transform an object into a different type.

&7 Tocue

&4 To Polygon
Srou

To Contour Eoth:ine

To 3D )
q — ) ) Shapes v
&% To 3D Rotation Object c ¢

. onnec
To Btmap B
) Ereak
To Metafile

B custom Animation...
& Interaction...

¥ cut
Copy

[ Paste

Figure 21: The convert options in the context menu- redo with
submenu on right, next to little arrow by Convert

Right-click on the object and select the Convert menu. The menu of Figure 21 will open
allowing you to select one of the following options:

« To Curve: converts the selected object to a Bézier curve.

- To Polygon: converts the selected object to a polygon. After the conversion choose
Edit Points to edit the shape.

« To Contour: converts the selected object to a polygon, or a group of polygons. If the
conversion creates a group of polygons (for example, when you convert a text object),
then press F3 to enter the group before you can select an individual polygon.

- Convert to 3D: converts the selected object to a three-dimensional (3D) object.

- Convert to 3D Rotation Object: creates a three-dimensional shape by rotating the
selected object around its vertical axis.

- To Bitmap: converts the selected object to a bitmap.

- To metafile: converts the selected object to Windows Metafile Format (WMF),
containing both bitmap and vector graphic data.

Grouping shapes together

It is often convenient to group shapes together so that they are treated as a single shape by
Impress. A group of shapes can be formatted as if it was a single shape, moved, rotated,
deleted and so on. To group shapes together, do as follows:

1) Select the shapes to be grouped. To do this, use the selection tool on the drawing
toolbar and draw a rectangle around the shapes to be grouped, or click on each shape
to be added to the group while pressing the Shift key.
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2) When the green resizing handles show, select Format > Group > Group or press
Control+Shift+G on the keyboard.

Once the group is defined, click on any of the shapes in the group to select the group. To edit
only the elements of the group, press F3 when the group is selected or select Format >
Group > Enter group from the menu bar. Notice that the elements not part of the group are
grayed out and that only the shapes belonging to the group can be edited. Use this
functionality when you need to apply a particular format to a single member of the group. To
exit from group mode, press Control+F3 or select Format > Group > Exit group from the
menu bar.

For more about working with grouped objects, see Chapter 6, “Combining Multiple Objects”
in the Draw Guide.

To ungroup objects:
1) Select the group of shapes.

2) When the green resizing handles show, select Edit > Format > Group > Ungroup
from the menu bar.

Tip If you use the grouping and ungrouping often, why not adding them to one of the
toolbars shown by default so that the commands are readily available? To do so, you
will need to customize the selected toolbar. See Chapter xx.

Using Graphic styles to format graphics

To apply the same formatting to a large number of objects, the best approach is to use styles
to set the formatting attributes. If a style is modified (for example, by changing the area
transparency), the changes are automatically applied to all the graphics with that style. Using
the inheritance properties of styles also achieves professional results in a short time. For
example, if multiple lines change in color but are otherwise identically formatted, the best
way to proceed is to define a generic style for the line and a number of hierarchically
dependent styles which only differ in the line color attribute. If later you need to change the
arrowhead style or the thickness of the lines, it is sufficient to change the parent style and all
the other styles will change accordingly.

To create a new style, select all the attributes of the graphic objects to which the style will be
applied. As shown in Figure 22, the style dialog consists of 15 pages.

« The Organizer page, which contains a summary of the style and its hierarchical
position, is discussed in Chapter 2.

« The Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian typography
pages, which set the properties of the text, are discussed in detail in Chapter 3.

« The Dimensioning page is normally not used in presentations. For further details refer
to the Draw Guide.
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+ The remaining pages (Text, Text animation, Connector, Line, Area, Shadowing, and
Transparency) are the same as the corresponding pages on the Line, Area, and Text
dialogs used for manual formatting, discussed earlier in this chapter.

To apply a style, select the object (or objects) and click on the style from the Styles and
Formatting window. If the window is not showing, press F'/1, or click the Styles and
Formatting icon at the left-hand end of the formatting bar, or select Format > Styles and
Formatting from the menu bar. Press F'// again when the dialog is not needed, to maximize
the workspace area.

Graphics styles: MyRectangle

Text | Text Animation | Dimensioning | Connector | Alignment | Asian Typography | Tabs |
Organizer Line | Area | Shadowing | Transparency | Font | Font Effect | Indents & Spacing |

MName MyRectangle

Linked with Default :
Category Custom Styles s
Contains

Invisible + Dashed 2 + Continuous + Gradient 8 + Hatching 1 + Bitmap 1 + Shadow an
+ Shadow spacing X 0.1cm + Shadow spacing ¥ 0.1cm + AutoFit height off + Vertical
text anchor Center + Horizontal text anchor Use entire width + Centered + Architect +
bold

" ook Cancel Help Reset Standard

Figure 22: The dialog for defining a custom graphic style

Using Fontwork

Use Fontwork to obtain special text effects. For more about this topic, see Chapter 15, “Using
Fontwork” in the Getting Started book.

To start using Fontwork:

1) Open the Fontwork Gallery by clicking the Bl icon on the Drawing toolbar (see
Figure 5) or on the Fontwork toolbar (see Figure 25). If the Drawing toolbar is not
showing, you can go directly to the Fontwork toolbar by selecting View > Toolbars >
Fontwork from the main menu bar.
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2) Select from the Fontwork Gallery (Figure 23) the preferred style and click OK. You
can modify it later, so pick one providing an effect similar to the desired one. The text
Fontwork in the selected style appears on the slide (Figure 24).

—

— Fontworlk Gallery

Select a Fontwark style:

O ™ S
e N
A e s | e

Fopfyork

QK | Cancel | Help |

Figure 23: The Fontwork gallery

3) Double-click the object to edit the Fontwork text. Type your own text in place of the
black Fontwork that appears over the object (Figure 24).

o ke

Figure 24. Editing Fontwork text

4) Press the Esc key or click outside the area with the blue resizing handles to exit.

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you
can use the Fontwork toolbar or other options as described in the next section.
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Using the Fontwork toolbar

Make sure that the Fontwork toolbar, shown in Figure 25, is visible on the workspace. If not,
select View > Toolbars > Fontwork from the main menu bar.

Fontwork v X
B Y -Ad =AY
Figure 25: The Fontwork toolbar

In addition to the Fontwork Gallery icon, this toolbar contains the following icons:

V- Fontwork shape: to change the shape of the selected object, choose a shape from
the extended toolbar (Figure 26).

Fontwork Shape +* X
=l e ® =

Eoey P OH &

Figure 26: The extended shapes toolbar

A8 pontwork Same Letter Heights: Changes the height of characters in the object.
Toggles between normal height (some characters taller than others, for example capital
letters, d, h, 1 and others) and all letters the same height. See Figure 27.

oo FOIOIE

Figure 27. Left: normal letters, right: same letter heights

" Fontwork Alignment: specify the alignment of the text within the frame from the
choices available in Figure 28. The effects of the text alignment can only be appreciated if
the text spans over two or more lines. In the Stretch Justify mode all the lines are filled
completely.
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=' -ontwork A XI
E Left Align

= Center
Right Align

Waord Justify
Stretch Justify

11l

Figure 28: The extended alignment toolbar

Av -
N Fontwork Character Spacing: select the desired spacing (Figure 29) and whether

kerning pairs should be used. For custom spacing, input a percentage value: 100% is
normal spacing; less than 100% is tight spacing; more than 100% is expanded spacing.

= Fontwork Chara B4
| Wery Tight

Tight

MNormal
o Loose

“ery Loose
Custom...

Kern Character Pairs

Figure 29: The extended character spacing toolbar

Modifying Fontwork text as a shape

It is possible to treat Fontwork text as a shape and therefore to apply to it all the formatting
that has been described in this chapter. Assign line properties only to Fontwork which does
not have a 3D effect, otherwise the changes will not be visible.

Tip Change the Fontwork color quickly using the Area fill color swatch on the Line and
Filling toolbar.

In the same way as it is possible to modify the angles of Trapezoids and Parallelogram basic
shape by moving the yellow dot that is displayed along with the blue resizing handles, it is
possible to modify the shape of some of the Fontwork.

Alignment using the grid and snap guides

The section “Aligning shapes” on page 17 discussed the alignment of objects relative to each
other or to the page border. However, sometimes it is important to align objects to specific
points of the page or to make sure that objects that appear on multiple slides are placed in
exactly the same position. For this purpose Impress provides two mechanisms: the Grid and
the Snap Guides (also called Snap Lines).
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Using the grid

Options for the grid are available in the menu that opens by right-clicking on an empty part of
the page in Normal view and choosing Grid or by selecting View > Grid from the menu bar.
In both cases a submenu with three options opens:

+ Visible Grid: displays the grid.

« Snap to Grid: the anchor points of an object will always be placed on a grid when the
object is moved or resized.

+ Grid to Front: displays the grid in the foreground.

To set up the grid spacing and snapping options, choose Tools > Options > OpenOffice.org
Impress > Grid from the menu bar.

Using snap guides

Options for the guides are available in the menu that opens by clicking on an empty part of
the page in Normal view and choosing Snap Lines or by selecting View > Guides from the
menu bar. A submenu with three options opens:

+ Visible Guides (Snap Lines Visible): the guides are shown on the slide.

+ Snap to Guides (Snap to Snap Lines): the anchor points of the objects snap to the
guides when the objet is moved or resized.

+ Guides to Front (Snap Lines to Front): the guides are brought to the foreground and
cover the objects.

Note The main menu uses the term Guides, but the pop-up menu refers to Snap Lines.

To create a new Guide:

1) Right-click on an empty part of the work area and select Insert Snap Point/Line from
the pop-up menu.

2) In the dialog that appears, specify the type (Point, Vertical line, or Horizontal line).

3) Depending on the choice made, the two edit fields X and Y become active; enter the
position of the Guide.

4) Click OK to close the dialog.

Tip When positioning the Snap Guides, it is useful to display the rulers. To do so, select
View > Rulers.

Tip Drag a Snap Guide directly onto the slide by clicking on the ruler and then dragging
onto the slide.

To edit a Guide:
1) Right-click next to or on the guide to be edited.
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2) Select Edit Snap line from the pop-up menu.

3) Enter the new value (or values) and click OK.
To delete a Guide:

1) Right-click next or on the guide to be deleted.

2) Choose Delete Snap line from the pop-up menu.

Figure 30 show the three types of guides, the grid on a slide, and the dialog to create a new
Guide.

Normal Outline | Nu:ute5| Handuut| slide Sorter |
+/ 1 2 3 456 7 8 91011 ]{2131415161?18192021 22 23 24 25 26 27 2

Snap Point

\

Ventical snap
line

Haornizontal
snap line

Position

F oK
% p.oocm - -
Cancel

-

¥ 0.00cm -

Type Help

Point

g

12019181716151413121110 9 B 7 6 5 4 3 2 1

F i‘éure 30: Gridline, snap lines and snap point on a slide

Managing glue points

As discussed in “Formatting connectors” on page 15, a glue point is the point of attachment
for a connector. To define new glue points and edit them, use the Gluepoints toolbar, shown
in Figure 31.
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Gluepoints v X
=g ® @
Figure 31: The Gluepoint toolbar

Use the first tool to insert a new glue point. The next four tools determine the exit direction
of the connector terminating at the glue point. To maintain the relative position of the glue
point when resizing the object, make sure that the Glue point relative icon is pressed.
Deselecting the Glue point relative icon enables the next six icons of the toolbar; use these
to fix the position of the gluepoint during the resizing of the object. Hover the mouse over the
buttons to obtain a tooltip giving a short description of the functionality.

To delete a custom glue point, select it with the mouse and press the Delete key.

Setting custom glue points is particularly useful where multiple connectors terminate on the
same side of a shape or where the default glue point position is not satisfactory.

Setting up interaction with a shape or image

You can associate with a shape or an image some action to be performed when the user clicks
on it. To create an interaction:

1) Select the graphic object for which an interaction will be created.
2) When the green handles show, select from the Drawing toolbar (Figure 5) the

Interaction button @ or right-click on the object and select Interaction from the
rpop-up menu.

3) The dialog shown in Figure 32 is displayed. Select the interaction type and the
parameters (if applicable).

4) Click OK to close the dialog.

|
Target O
Slide 2 —
[ slide 2 (Notes)
[ Slide 3
[ slide 3 (Notes)
[ Slide 4

[ slide 4 (Notes)
[ edul (Handouts)

e Y |

[

Slide / Object
Slide 1 [ Find

Figure 32: Dialog to set the interaction with a graphic object

To remove an interaction from a graphic object follow the steps 1-5, above taking care to
select No action as the interaction type at step 4.
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Setting up interaction with a shape or image

The possible actions and their parameters are described in Table 2.

Table 2: Interactions and their parameters

Interaction type Parameters

Go to Previous slide

No parameters.

Go to Next slide

No parameters.

Go to First slide

No parameters.

Go to Last slide

No parameters.

Go to Page or Object

Specify the target from the list in the Target box. You can
search for a specific target in the Document box at the
bottom of the screen.

Go to Document

Select the document in the Document box. Use the Browse
button to open a file picker dialog. If the document to be
opened is in Open Document Presentation format, the
target list will be populated allowing the selection of the
specific target in the document.

Play sound

Select the file containing the sound to be played. Use the
Browse button to open a file picker dialog.

Run program

Select the program to execute. Use the Browse button to
locate it.

Run Macro Select a macro that will run during the presentation. Use
the Browse button to open the macro browser dialog.
Exit presentation When the mouse is clicked over the graphic object, the

presentation will terminate.

Animating images

Impress offers some animation functionalities that are typical of specialized programs. An
animated image consists of a sequence of images (frames) that are displayed in succession.

Each frame may contain one or multiple drawing objects. To start creating a custom animated
image open the Animator dialog from Insert > Animated Image (see Figure 33).
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Figure 33: The Animator dialog

Creating an animation

There are several mechanisms that can be used to create an animated image, in this chapter
only two of them will be described as they should be sufficient to understand the various
functionalities offered.

Frame by frame animation:
1) Create the image you intend to animate using the drawing tools.

(]
2) Select the image and press the Apply Object b This will copy the object (or
objects) into the upper part of the animator window.

3) Apply some transformation to the object, for example rotate it, change the color, if you
are animating a text add or subtract a letter and so on.

4) When you are ready, create the second frame of the animation clicking again the apply
object.

5) Repeat steps 3 and 4 until you have created all the desired frames of the animation.

6) Select the radio button Bitmap object part of the Animation group section of the
Animator dialog. This will allow you to customize the timing of each of the frames
and the number of repetitions for the animation (set the value to Max to obtain an
infinite loop).
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7) Press the Create button to place the animated image on the slide.

Note If the image to be copied in the Animator consists of several objects, you can choose
to treat each object as a separate frame. In this case press the Apply objects

individually button & . Remember that each object will be centered in the
animation.

Animated image in one go

For some simple animations it is possible to create all the animation frames in advance, and
place them on the slide. This method works well for a rotating line, a shape gradually
changing color, shapes increasing or decreasing size. In most of these occasions it is
convenient to use the Edit > Duplicate command.

o

When all the frames are already prepared, use the Apply objects individually to create

one frame for each of the objects.
It is easy to obtain for example a rotating segment:

1) Draw a segment, say, horizontal and make it fairly thick (use Format > Line or the
Line and Filling toolbar to do that).

2) Open the Duplicate dialog by selecting Edit > Duplicate and set the number of copies
to 5, the X and Y axis to 0.1, the angle to 30, the enlargement width and height to 0,
and press the OK button.

3) Select the 6 segments created by Impress and open the Animator (Insert > Animated
image from the main menu bar).

4) Click on the Animator dialog Apply objects individually.
5) Select Bitmap object in the lower part of the dialog, then click the Create button.

Other functionalities of the Animator and Tips

You can review the animation at any time by pressing the Play button 4

the various frames using the other controls available.

as well as navigate

If you are not satisfied of a particular frame you can remove it, to do so:

1) Navigate to the frame using the edit control with the spin buttons.

Ek .

2) Press the Delete current image button

@ .

You can also delete the whole animation pressing the Delete all images button

Tip In case you want to work on the animation frames a bit more, you can copy them
into the Impress work area by selecting the Group object and then clicking the
Create button.
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Tip Since all the objects are centered in the animation window, to animate an object off
the center of the image, create a blank rectangle of the same size of the final image
and select it along with the object to be animated. Make sure that the Group object
is selected before pressing the Apply object button.

Working with 3D shapes

3D graphic objects can be created in different ways in Impress:

+  From the 3D-Objects toolbar. The 3D-Objects tool is not included in the default
Drawing toolbar. To include it, click on the small triangle at the end of the toolbar,
select Visible Buttons, and select 3D-Objects from the list. On the Drawing toolbar,
click on the triangle by the 3D-Objects icon to display the extended 3D Objects toolbar
(Figure 34).

3D-0Objects v X
gdagdsareee
Figure 34: 3D-Objects extended toolbar

«  From Convert menu as Rotation. Select an object, right-click on it, then select
Convert and select To 3D Rotation Object.

+ From the Extrusion on/off icon on the drawing toolbar. Select the shape to which

apply a 3D effect, then click the & button on the Drawing toolbar (see Figure 35).

Caution You can not apply extrusion to rectangular and oval shapes created using the
rectangle and the oval tools respectively. To create a rectangle or oval with 3D
A effects, select the desired shape from the basic shapes menu. Alternatively, right-
click on the object then select Convert > To 3D. Note though that in this case the
extrusion on/off menu will not be enabled.

Although Impress offers advanced functionalities to manipulate 3D objects, this book
describes only the 3D settings applicable to an object with Extrusion enabled. For additional
information on how to use advanced 3D eftects such as geometry, shading, and so on, refer to
the Draw Guide.

Click on & to activate the extrusion. The shape changes and a default thickness is added to
it. At the same time the 3D-Settings toolbar (Figure 35) should become visible. If the toolbar
does not appear, select View > Toolbars > 3D-Settings.

3D-Settings v X
@ P F-g- -w-4-
Figure 35: The 3D-Settings toolbar

Use the tools to change the appearance of the 3D object.
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& Extrusion On/Off: adds thickness to an object and activates the 3D properties.
S Tilt Down: tilts the object downwards around an horizontal axis.

¢ Tilt Up: tilts the object up around an horizontal axis.

P Tilt Left: tilts the object left around a vertical axis.

o Tilt Right: tilts the object right around a vertical axis.

o - Depth: determines the thickness of the shape. An extended toolbar opens where
some default values are given. If none of them is satisfactory, select Custom and then

enter the desired thickness.

& - Direction: pick the direction of the perspective as well as the type among parallel
and perspective from the extended toolbar that opens when clicking the button.

" Lighting: specify the direction of the light as well as its intensity from the extended
toolbar that opens when clicking this button.

- Surface: choose between Wire frame (useful when manipulating the object), Matt,
Plastic or Metal.

g- 3D Color: select the color of the object thickness.

Most of the Fontwork shapes (see the corresponding section on page 20) have 3D properties
and can be manipulated with the 3D-Settings toolbar.

Note that when rotating a 3D object, in addition to the corner red handles, the four handles on
the sides of the frame become available.

Figure 36 is an example of customized 3D object.

5 7Authors

Figure 36: Example of 3D object
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